G&R Tactical
Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: T-2 brightness issue?

  1. #11
    Join Date
    Mar 2016
    Location
    Tampa, FL
    Posts
    58
    Feedback Score
    18 (100%)
    I have a few Aimpoints that I leave on constantly. My old T1 has been on for two years, PRO for about two years as well, ACO maybe a year now? And one of my M4s for about 4 years on that AAA. I'm due to change some batteries...
    Last edited by BCMNick; 03-14-18 at 01:53.

  2. #12
    Join Date
    Dec 2011
    Location
    O'ahu
    Posts
    5,370
    Feedback Score
    77 (100%)
    I reached out to Aimpoint today after noticing that my dot was barely visible again. The last battery replacement was when I started this thread but I do keep it at setting 11 to account for the brightness of the M300C. I understand that is higher than the published spec which I think is setting eight, but five years at that setting vs five months at setting 11 doesn't seem that great. We'll see what they say.
    Sic semper tyrannis.

  3. #13
    Join Date
    Dec 2011
    Location
    O'ahu
    Posts
    5,370
    Feedback Score
    77 (100%)
    Aim point got back to me today and gave me the following numbers which Iíve yet to see elsewhere: Position 9 = 25,000. 10 = 12,500. 11 = 6,250. 12 = 3,125.

    That is a significant decrease for every setting and explains why I always have to replace my battery so often. Guess Iíll mess around with mine at setting 10 and see how much of a difference that is.


    Sent from my iPhone using Tapatalk
    Sic semper tyrannis.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •