Page 5 of 5 FirstFirst ... 345
Results 41 to 47 of 47

Thread: Gas tube problems

  1. #41
    Join Date
    Feb 2016
    Location
    Mars
    Posts
    1,337
    Feedback Score
    14 (100%)
    What ammo were you using? Temperature?

    The Hanson barrel came with a pinned gas block and you are running a csrbine length gas tube, correct? Are you using the gas block that came with the Hanson barrel?

    Were the bolt and bolt carrier well lubed? Do you have all 3 gas rings in the bolt?

    Bolt/bolt carrier look good? Are you 100% that the gas key is clear on the BCG? You can blow into it and should feel very little resistance.

    Remove the upper and the charging handle and take the bolt out of the bolt carrier. With the upper upside down, insert the bolt carrier (only) into the upper and verify the gas tube enters the bolt carrier cleanly. Re-assemble and hand cycle the action - does it feel or sound like it's binding or rubbing?

    My 11.3 Hanson has been problem free with a H2 buffer and standard (quality) carbine action spring, and I have shot it quite a bit since assembling it in June.

    Andy

    P.S. not sure why I typed "pistol" length tube.
    Last edited by AndyLate; 01-21-20 at 22:05.

  2. #42
    Join Date
    Sep 2019
    Posts
    23
    Feedback Score
    0
    The ammo was federal american eagle 55 gr. I'm using s carbine length tube now and it's the block that came on the barrel, bolt and carrier were lubed well. And I will check the rings and make sure everything is functioning right tomorrow I was told earlier that the spring and weight have several thousand rounds on them so I'm planning to swap those in the next few days along with a nickel boron bcg.

  3. #43
    Join Date
    Sep 2019
    Posts
    23
    Feedback Score
    0
    20191125_150117.jpg nickel bcg in will hopefully shooting it sunday

  4. #44
    Join Date
    Sep 2019
    Posts
    23
    Feedback Score
    0
    Rifle ran perfectly after new bcg. Ran just under 300 rounds through it without any sort of failure will be putting a rise armament sst trigger in it tomorrow then shooting again Sunday.

  5. #45
    Join Date
    Sep 2009
    Posts
    40
    Feedback Score
    0
    Quote Originally Posted by Yimmy View Post
    Attachment 59770 this is it. Shot about 250 rounds and started short stroking again.
    Quote Originally Posted by Yimmy View Post
    I finished putting it together this evening I will post pictures tomorrow some time, but I ended up with a kak slimline in the end of the barrel but would I need a stamp with that?
    you’ll need a tax stamp running that fvg on your pistol unless the oal is 26” or more...
    Last edited by INMY01TA; 01-20-20 at 09:37.

  6. #46
    Join Date
    Feb 2016
    Location
    Mars
    Posts
    1,337
    Feedback Score
    14 (100%)
    Quote Originally Posted by Yimmy View Post
    Rifle ran perfectly after new bcg. Ran just under 300 rounds through it without any sort of failure will be putting a rise armament sst trigger in it tomorrow then shooting again Sunday.
    That's good news!

  7. #47
    Join Date
    Sep 2019
    Posts
    23
    Feedback Score
    0
    Put a couple thousand rounds through it since my last post here running great still! Recently put on the vg6 epsilon brake and it keeps it pretty flat, side blast is pretty gnarly as other have said the cases are ejecting to my two o clock so I may get a new spring or adjustable weight but in the meantime I'm happy with it.

Page 5 of 5 FirstFirst ... 345

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •