Page 5 of 5 FirstFirst ... 345
Results 41 to 49 of 49

Thread: Help - Weird New Double Feed LMT

  1. #41
    Join Date
    Mar 2017
    Posts
    687
    Feedback Score
    2 (100%)
    Ah. No. Don't have a can. But it malfed on you unsuppressed.

    Did you ever try it other mags or just the Pmags?
    Last edited by 17K; 03-12-20 at 21:40.

  2. #42
    Join Date
    Feb 2019
    Posts
    83
    Feedback Score
    1 (100%)
    This is true too. Yeah idk man. Ejection pattern and rifle history doesnt indicate it's near failure. It's now at about 1500rds suppressed without a cleaning and working like a top. All I know is the grip came loose, I got weird magazine malfunctions. When the grip was tightened, the malfunctions stopped.

  3. #43
    Join Date
    Mar 2017
    Posts
    687
    Feedback Score
    2 (100%)
    I'm just trying to figure it out because it's weird!

    I wish you would try it with some known good g.i. mags and see if it acted different.

  4. #44
    Join Date
    Feb 2019
    Posts
    83
    Feedback Score
    1 (100%)
    I did. All the Okay Ind. Mags are G.I. that I have used with zero issues of any kind prior to that. Them now production surefeeds. Then magpul. Then DD. Since the grip has been tightened, no problems or even the feel of anything weird from any of them. The only thing I could do to stest is loosen the grip again and see how it goes, but I'd rather not. The grip was so loose I'm surprised the safety selector wasnt spinn ik ng freely

  5. #45
    Join Date
    Dec 2019
    Location
    Cradle of the Confederacy
    Posts
    183
    Feedback Score
    0
    I think what you have here is a mag problem. Number your mags, keep a log of stoppages indicating type, mag number, round number ( like 5th round failed) and what the failure was.

    Even better if you have more than one AR run same mags in different rifle or a friend's rifle. If same thing happens in other rifles you know you have a mag problem. Most AR stoppages happen in first three rounds from a full 30 round mag.

  6. #46
    Join Date
    Nov 2016
    Posts
    37
    Feedback Score
    0
    He's mentioned that the failures have occurred with multiple different magazines, all of which have worked fine in other rifles.

  7. #47
    Join Date
    Nov 2013
    Posts
    21
    Feedback Score
    0
    I don't know if this helps, but I switched to a heavier spring and buffer in my LMT MWS 308 to shoot while suppresed. Turns out it was oversprung and caused similar malfunctions. I switched back to the factory spring, but kept the heavier buffer installed. Problem solved. Good luck!

  8. #48
    Join Date
    Feb 2019
    Posts
    83
    Feedback Score
    1 (100%)
    The problem went away with the tightened grip. I tried every buffer weight from carbine to H3 with no change while the malfunctions were happening. I'm 99.99% it was somehow related to the pistol grip. Thanks though!

  9. #49
    Join Date
    Nov 2013
    Posts
    21
    Feedback Score
    0
    LMT makes great stuff. I'm glad it was a simple fix. Guns are weird haha.

Page 5 of 5 FirstFirst ... 345

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •