Results 1 to 9 of 9

Thread: Not getting bolt lockback when suppressed

  1. #1
    Join Date
    Oct 2015
    Posts
    146
    Feedback Score
    7 (100%)

    Not getting bolt lockback when suppressed

    16 inch mid, it's ran totally flawless until throwing my can on. With an H2, I have tried a regular BCG, LMT enhanced BCG, every buffer spring imaginable up to and including a sprinco red, but 99% of the time the bolt won't lock back on an empty mag. It will lock every time without the can on, doesn't seem to be insanely overgased or anything. Not trying to throw anyone under the bus but it's a LMT MRP, and I think it could have been ported a little smaller.. but I am not getting a bunch of gas to face with the enhanced bcg, and it doesn't feel like it's beating itself up or anything.

    I threw the upper on another lower (H2, carbine spring), and loaded up an assortment of different mags with 1 round and they all locked back. I know undergassed barrels obviously won't lock back, just at a loss here. I get that the bolt could be outrunning something...but I don't get why it won't work on a MARS lower, but will function fine on another.

  2. #2
    Join Date
    Jun 2009
    Location
    Allentown, PA
    Posts
    3,369
    Feedback Score
    58 (100%)
    I’m guessing you have tried this with different mags? Try different brands?
    How about your action spring? Sounds like your bolt is outrunning you mag spring.
    "Perfect Practice Makes Perfect"
    "There are 550 million firearms on this planet. That's one firearm for every 12 people. The question is... How do we arm the other 11?" Lord of War.
    "I predict future happiness for Americans if they can prevent the government from wasting the labors of the people under the pretense of taking care of them." Thomas Jefferson

  3. #3
    Join Date
    Sep 2007
    Location
    AZ
    Posts
    27,024
    Feedback Score
    14 (100%)
    I have a BCM 14.5 middy suppressed that hates to lock back for some reason. It's not excessively overgassed with the can, and definitely runs on the leaner side without the can.

    Could be a thing with the middy length. I know I've had carbine gas systems that were way more gassy feeling that didn't do the same thing.
    "You people have too much time on your hands." - scottryan

  4. #4
    Join Date
    Dec 2009
    Location
    Utah
    Posts
    8,345
    Feedback Score
    3 (100%)
    It's likely your upper is over gassed with the suppressor installed, but lets take a look at the most telling fact-
    Quote Originally Posted by Torquetard View Post
    ...I threw the upper on another lower (H2, carbine spring), and loaded up an assortment of different mags with 1 round and they all locked back...I get that the bolt could be outrunning something...but I don't get why it won't work on a MARS lower, but will function fine on another.
    The problem is the mag catch. The mag catch isn't adjusted right. I've had the same problem with a couple of my lowers. If the mag catch doesn't hold the mag tight enough, the follower won't engage the BHO firmly. Without the suppressor, it works fine. But the added speed the carrier from shooting suppressed is knocking the follower away from the BHO. If you tighten up the mag release button a bit (probably from a half turn to a turn and a half) it will solve the issue.
    Last edited by MistWolf; 09-15-20 at 18:19.
    INSIDE PLAN OF BOX
    1. ROAD-RUNNER LIFTS GLASS OF WATER- PULLING UP MATCH
    2. MATCH SCRATCHES ON MATCH-BOX
    3. MATCH LIGHTS FUSE TO TNT
    4. BOOM!
    5. HA-HA!!

    -WILE E. COYOTE, AUTHOR OF "EVERYTHING I NEEDED TO KNOW IN LIFE, I LEARNED FROM GOLDBERG & MURPHY"

    http://i115.photobucket.com/albums/n289/SgtSongDog/AR%20Carbine/DSC_0114.jpg
    I am American

  5. #5
    Join Date
    Oct 2015
    Posts
    146
    Feedback Score
    7 (100%)
    Quote Originally Posted by MistWolf View Post
    It's likely your upper is over gassed with the suppressor installed, but lets take a look at the most telling fact-

    The problem is the mag catch. The mag catch isn't adjusted right. I've had the same problem with a couple of my lowers. If the mag catch doesn't hold the mag tight enough, the follower won't engage the BHO firmly. Without the suppressor, it works fine. But the added speed the carrier from shooting suppressed is knocking the follower away from the BHO. If you tighten up the mag release button a bit (probably from a half turn to a turn and a half) it will solve the issue.
    I actually did try that, but only gave it one turn. I gave it another one and it's just about as tight as it will go now. I'll see if it helps next time, thanks

  6. #6
    Join Date
    Sep 2007
    Location
    AZ
    Posts
    27,024
    Feedback Score
    14 (100%)
    Another thing I had an issue with was the bolt catch spring. I had one lower years back that I had to trim the spring because, compared to other known lowers, it was way stiffer.
    "You people have too much time on your hands." - scottryan

  7. #7
    Join Date
    Aug 2011
    Location
    E. Tennessee
    Posts
    2,074
    Feedback Score
    6 (100%)
    Interesting. Don’t think I have seen that issue before. Good to know though.
    Quote Originally Posted by MistWolf View Post
    It's likely your upper is over gassed with the suppressor installed, but lets take a look at the most telling fact-

    The problem is the mag catch. The mag catch isn't adjusted right. I've had the same problem with a couple of my lowers. If the mag catch doesn't hold the mag tight enough, the follower won't engage the BHO firmly. Without the suppressor, it works fine. But the added speed the carrier from shooting suppressed is knocking the follower away from the BHO. If you tighten up the mag release button a bit (probably from a half turn to a turn and a half) it will solve the issue.
    ETC (SW/AW), USN (1998-2008)
    CVN-65, USS Enterprise

  8. #8
    Join Date
    Aug 2011
    Location
    E. Tennessee
    Posts
    2,074
    Feedback Score
    6 (100%)
    Double....
    Last edited by hotrodder636; 09-16-20 at 11:57.
    ETC (SW/AW), USN (1998-2008)
    CVN-65, USS Enterprise

  9. #9
    Join Date
    Mar 2017
    Posts
    325
    Feedback Score
    5 (100%)
    I'm having an issue with a mars lower MRP upper not locking back, it was sent in and they could not duplicate the problem so nothing was done. Noveske barreled upper and it locks back consistently. Both 16" mid length, neither suppressed. They can be finicky I'm thinking.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •