Results 1 to 5 of 5

Thread: CzP09 tactical not cycling with can

  1. #1
    Join Date
    Nov 2021
    Posts
    24
    Feedback Score
    0

    CzP09 tactical not cycling with can

    So I have a Silencerco hybrid 46 that I run on my long guns and shorties. I recently bought the 9mm pistol piston so I coul also run it on my CZP09 tactical. Problem is, it won’t cycle. Super quiet, but I have to rack the slide every time. Am I missing something? Anyone else seen this? Do I need to change out my spring, or….?
    Last edited by Coloradocarbine; 01-26-22 at 15:34. Reason: Misspelled

  2. #2
    Join Date
    Dec 2012
    Location
    Atlanta, GA
    Posts
    517
    Feedback Score
    4 (100%)
    Is the fixed spacer or piston spring installed. The later is for non blowback pistols.

  3. #3
    Join Date
    Nov 2021
    Posts
    24
    Feedback Score
    0
    Will need to look again. I know I had a spring installed, yes. Came with the pistol kit for 9mm

  4. #4
    Join Date
    Nov 2007
    Location
    Georgia, USA
    Posts
    3,126
    Feedback Score
    0
    If you don't have the Neilsen device (spring) installed, it won't run.

  5. #5
    Join Date
    Nov 2021
    Posts
    24
    Feedback Score
    0
    I had it installed. Looking around it seems the p09/p10 have had some issues running suppressed. Couple hundred round break in needed with suppressor on, or changing springs in gun needed sometimes

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •