G&R Tactical
Results 1 to 7 of 7

Thread: Need Help, 870 Safety "locked"

  1. #1
    Join Date
    Mar 2007
    Posts
    53
    Feedback Score
    0

    Need Help, 870 Safety "locked"

    I have an older 870 Police that has ran true for thousands of rounds. Today I had an issue I have never encountered. It seemed that my safety was half way engaged and I could not pull the trigger of release the safety to fire the weapon. I was shooting a stage at a local match and engaged the safety during a reload. I ejected all the shells, left the line and was able to manipulate the safety, then tried dry firing and everything was fine.... No issues.
    The shotgun was relatively clean and I remember concentrating on racking it with purpose so as not to short stroke. The safety is a large head safety that I installed many hundreds of rounds ago. Any ideas how to prevent this in the future or what may have happened? I guessing stress and the heat monster got me and I did not manipulate the safety all the way.
    Thanks
    R/
    Mike

  2. #2
    Join Date
    Feb 2009
    Posts
    2,433
    Feedback Score
    2 (100%)
    You might call Hans Vang and ask him. He would know.
    "First gett'n shot, then gett'n married... baaaad habits"

    "If you're gonna subscribe to hero worship, at least worship a real hero."
    M4Guru

    Gal 2:20

  3. #3
    Join Date
    Jan 2008
    Location
    AZ-Waging jihad against crappy AR's.
    Posts
    24,902
    Feedback Score
    104 (100%)
    I would remove the trigger unit and do an inspection. Look for anything unusual. I would maybe put a small drop of lube there as well and work the safety. I think maybe in the heat of things you just screwed up somehow.



    Owner/Instructor at Semper Paratus Arms

    Facebook: https://www.facebook.com/SemperParatusArms/

    Semper Paratus Arms AR15 Armorer Course http://www.semperparatusarms.com/cou...-registration/

    M4C Misc. Training and Course Announcements- http://www.m4carbine.net/forumdisplay.php?f=141

    Master Armorer/R&D at SIONICS Weapon Systems- http://sionicsweaponsystems.com

  4. #4
    Join Date
    Dec 2009
    Posts
    103
    Feedback Score
    1 (100%)
    The detent, or detent spring in the safety could be worn if the gun's seen a lot of use. It happens to our range guns pretty frequently, but some of those have been on the line since '87.

    Replacing both would be cheap insurance.

  5. #5
    Join Date
    Jun 2006
    Location
    Virginia Beach, VA
    Posts
    270
    Feedback Score
    22 (100%)
    I had a similar situation with my 870. The Vang Comp safety was nearly impossible to operate. It ended up being a burr on the safety. Not sure how it got there but it was just enough to make it really difficult to operate it during a Rob Haught shotgun class last fall. I pulled it apart and smoothed it up and looked for anything abnormal. It may have been that way when I installed it and had just gotten worse. Either way, a quick meeting with the jeweler's file and some cold blue and it was all better and has been trouble free ever since. Pull it apart and do a visual on it then run a q-tip around the recess and the safety itself to see if it drags anything. If it does then it will more than likely be the cause. Something like replacing the safety, spring and detent ball are cheap insurance if you ever have your life depend on this shotgun. Hope it works out for you.
    Former Vickers Shooting Method REI
    914 Consulting LLC

  6. #6
    Join Date
    Sep 2010
    Posts
    51
    Feedback Score
    22 (100%)

    Need Help, 870 Safety "locked

    Assuming eveything was installted correctly,pull-out the trigger group assembly,then take the safety out. Now check the ball,spring and channel hole for any obstruction, cleaned and drop oil then re-assemble the unit, hopefully now it will work as they should.

  7. #7
    Join Date
    Mar 2007
    Posts
    53
    Feedback Score
    0
    All,
    Everything appeared good to go on inspection. I cleaned it and oiled it up and everything seems to work well now. I think I just goofed up ... operator error. I have been doing a lot of dry firing and reloading at the range and I have encountered this problem again yet.
    Thank you all.
    R/
    Mike
    PS Props to JD for his installation videos at AIP Tactical.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •